Features

Download

Online

Gallery

Blog

  Index  | Recent Threads  | List Attachments  | Help  | Search
 Welcome Guest  |  Register  |  Login
Login Name  Password
 

Sweet Home 3D Forum



No member browsing this thread
Thread Status: Active
Total posts in this thread: 73
Posts: 73   Pages: 8   [ Previous Page | 1 2 3 4 5 6 7 8 ]
[ Jump to Last Post ]
Post new Thread
Author
Previous Thread This topic has been viewed 19422 times and has 72 replies Next Thread
Puybaret
Expert
Member's Avatar

France
Joined: Nov 7, 2005
Post Count: 5814
Status: Offline
Reply to this Post  Reply with Quote 
Re: 3d View suddenly impossibly slow

In Sweet Home 3D 5.5 released last week, I added the 3 following options to Windows installer to let you choose the Java 3D version and architecture used by the program when there are some problems:
/os.arch=x86 will force the installation of the 32 bit version of Sweet Home 3D under Windows 64 bit
/j3d.version=1.5.2 will force the installation of Java 3D 1.5.2 (default Java 3D version until Windows 7)
/j3d.version=1.6 will force the installation of Java 3D 1.6 (default Java 3D version from Windows 8)

To use these options, simply execute the installer in a cmd window followed by the options of your choice separated by spaces. For example:
C:\SweetHome3D-5.5-windows.exe /j3d.version=1.5.2 /os.arch=x86

For people not used to commands, this can be achieved this way:
- Press <Windows> + R keys
- Type cmd and press <enter> key
- Drag and drop the icon of the installer SweetHome3D-5.5-windows.exe in the command window
- Type a space in the cmd window
- Copy /os.arch=x86 /j3d.version=1.5.2 and paste it in the cmd window
- Press <enter> key.

From you last comments, using Java 3D 1.5.2 after updating your graphics driver might be enough to run Sweet Home 3D under Windows 64 bit, in which case you could first try to run the installer with the option /j3d.version=1.5.2

I'm looking forward to reading your comments to be able to modify the FAQ accordingly.
----------------------------------------
Emmanuel Puybaret, Sweet Home 3D developer
[Sep 11, 2017 8:33:17 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest    http://www.eteks.com [Link] Report threatening or abusive post: please login first  Go to top 
rhawke
Newbie



United States
Joined: Dec 27, 2016
Post Count: 11
Status: Offline
Reply to this Post  Reply with Quote 
Re: 3d View suddenly impossibly slow

For some reason after a few days the old problem was back even though I didn't change anything. However, I had to replace my laptop this week and with the new one, also running Win 10, Java 1.8 and Java 3D 1.6 in 64 bit mode, everything worked fine right out of the box.

Good news, problem solved, bad news I won't be able to test the changes to the installer.
[Sep 21, 2017 6:03:29 PM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
ybon
Newbie




Joined: Nov 14, 2017
Post Count: 4
Status: Offline
Reply to this Post  Reply with Quote 
Re: 3d View suddenly impossibly slow

Hi,

Running SH3D after a long period without using it, seems I'm hitting the same issue: it's abnormaly slow.
For example, trying to draw a wall on a new project takes something like 5 seconds.
Sometimes it even takes longer for the wall to be drawn on the drawing area than on the 3D viewer.

I'm running Arch Linux on a Precision 5510, with i5-6300HQ Skylake CPUs, 16Gb of RAM.
Graphic card is a Nvidia GM107GLM (Quadro M1000M).
I've a 4k screen (3840x2160).

I'm running Java through OpenJDK 1.9:


java -version
openjdk version "9"
OpenJDK Runtime Environment (build 9+181)
OpenJDK 64-Bit Server VM (build 9+181, mixed mode)


Java 3D version is 1.6.0.

SH3D version is 5.5.2:




Here is some of my attemps to workaround the situation, but without luck:

- using OpenJDK 8
- java -Dcom.eteks.sweethome3d.j3d.version=1.5.2 -jar SweetHome3D-5.6.jar
- ./javaws SweetHome3D.jnlp


Any idea what more I should try/check to understand/fix the issue?

Thanks for your hints!

Yohan
[Nov 14, 2017 7:55:18 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
RalphB
Newbie



Germany
Joined: Jun 28, 2017
Post Count: 2
Status: Offline
Reply to this Post  Reply with Quote 
Re: 3d View suddenly impossibly slow

Many thanks to Emmanuel! The /j3d.version=1.5.2 option works for me. Not dirty trick anymore, just adding the Sweethome3D.l4j.ini with changed options and everything works fine. In my case no performance issues with Intel(R) Graphics Media Accelerator, Driver 9.14.3.1177 and Windows 10 32bit, 1607.

Many thanks again!
[Nov 18, 2017 9:02:20 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
ybon
Newbie




Joined: Nov 14, 2017
Post Count: 4
Status: Offline
Reply to this Post  Reply with Quote 
Re: 3d View suddenly impossibly slow

Quick follow-up:

- I've tested SweetHome3D on a fresh Ubuntu 17.10 install, and it frozen when I started drawing a wall (tried twice)



- back on my main computer running arch, I've tested SH3D version from 4.6 to 5.4, here is the summary


    * 4.6: responsiveness OK, HDPi support NOK (click is shifted, icons are two small, drawing grid is too small)
    * 5.0: responsiveness OK, HDPi support NOK (same)
    * 5.1: responsiveness OK, HDPi support NOK (same)
    * 5.2: responsiveness OK, HDPi support NOK (same)
    * 5.3: responsiveness NOK (oops), HDPi support OK (yay :))
    * 5.4: responsiveness NOK, HDPi support NOK (click is shifted, icons are two small, drawing grid is too small)
    * 5.5: responsiveness NOK, HDPi support NOK (same)
    * 5.5.2: responsiveness NOK, HDPi support NOK (same)


So, seems something is going on with 5.3 release. Given this release fixes the HDPi support (for me), it may be that the responsiveness issue is related.
Strangely, starting from 5.4, HDPi support is broken again (for me), but the responsiveness isn't fixed.
Sadly, from this quick investigation, I see that there is no release with both responsiveness and HDPi support for me.

Any hint out from those new elements? Anything I can test out?

Thanks :)
[Nov 18, 2017 9:46:42 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
ybon
Newbie




Joined: Nov 14, 2017
Post Count: 4
Status: Offline
Reply to this Post  Reply with Quote 
Re: 3d View suddenly impossibly slow

Tried to run 5.3 version without 3D view (adding -Dcom.eteks.sweethome3d.no3D=true argument), but the responsiveness issue is still present.

Also tried to pass -Dcom.eteks.sweethome3d.resolutionScale=2 to version before 5.3, but it does not seem to apply.
[Nov 18, 2017 10:19:06 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
ybon
Newbie




Joined: Nov 14, 2017
Post Count: 4
Status: Offline
Reply to this Post  Reply with Quote 
Re: 3d View suddenly impossibly slow

OK, adding all those parameters, I can run 5.2 with HDPi support and a normal responsiveness:

-Dcom.eteks.sweethome3d.resolutionScale=2 -Dswing.defaultlaf=javax.swing.plaf.metal.MetalLookAndFeel -Dswing.plaf.metal.controlFont=Dialog-12 -Dswing.plaf.metal.userFont=SansSerif-12 -Dswing.plaf.metal.systemFont=SansSerif-12

:)

Still interested by a fix to be able to run the latest release though :)
[Nov 18, 2017 3:38:19 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Posts: 73   Pages: 8   [ Previous Page | 1 2 3 4 5 6 7 8 ]
[ Jump to Last Post ]
Show Printable Version of Thread  Post new Thread

    Get Sweet Home 3D at SourceForge.net. Fast, secure and Free Open Source software downloads
   
© Copyright 2006-2017 eTeks - All rights reserved