Features

Download

Online

Gallery

Blog

  Index  | Recent Threads  | List Attachments  | Help  | Search
 Welcome Guest  |  Register  |  Login
Login Name  Password
 

Sweet Home 3D Forum



No member browsing this thread
Thread Status: Active
Total posts in this thread: 14
Posts: 14   Pages: 2   [ Previous Page | 1 2 ]
[ Jump to Last Post ]
Post new Thread
Author
Previous Thread This topic has been viewed 13852 times and has 13 replies Next Thread
Anna_Smith
Newbie




Joined: Jul 2, 2017
Post Count: 1
Status: Offline
Reply to this Post  Reply with Quote 
Re: SweetHome3D-5.3 gives 3D error on Ubuntu 16.04 with updated Nvidia driver (375.20)

Hi, I'm user of ubuntu 16 mate, and from two days I cannot use SweetHome because closes, when I want to go to options or preview.
My lap is old.. I3-380M with ATI Mobility Raedon HD 5470
I though the problem was Open Java but It seems not.
Can you help me?
Thanks.
[Jul 2, 2017 4:28:32 PM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
ghotrix
Newbie



Ukraine
Joined: Oct 10, 2017
Post Count: 1
Status: Offline
Reply to this Post  Reply with Quote 
Re: SweetHome3D-5.3 gives 3D error on Ubuntu 16.04 with updated Nvidia driver (375.20)

It just stuck for me during the SH3D execution.
[Oct 10, 2017 10:19:42 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
pivotz1
Newbie



Hungary
Joined: Nov 5, 2017
Post Count: 1
Status: Offline
Reply to this Post  Reply with Quote 
shock Re: SweetHome3D-5.3 gives 3D error on Ubuntu 16.04 with updated Nvidia driver (375.20)

Me too here! With driver 387.12.
It says, I must refresh my OpenGL drivers! Please check it!
[Nov 5, 2017 10:20:28 AM] Show Printable Version of Post    View Member Profile    Send Private Message [Link] Report threatening or abusive post: please login first  Go to top 
Uatschitchun
Newbie




Joined: Aug 25, 2018
Post Count: 1
Status: Offline
Reply to this Post  Reply with Quote 
Re: SweetHome3D-5.3 gives 3D error on Ubuntu 16.04 with updated Nvidia driver (375.20)

Hi, same problem here with bionic 18.04 & nvidia-drivers-390:

$ ./SweetHome3D
com.jogamp.opengl.GLException: J3D-Renderer-1: Error making temp context(1) current: display 0x7fac3c202840, context 0x7fac3c437be8, drawable X11OnscreenGLXDrawable[Realized true,
Factory jogamp.opengl.x11.glx.X11GLXDrawableFactory@5fb0c302,
Handle 0x8e00097,
Surface JAWTWindow[0x79e62686][JVM version: 1.8.0_162 (1.8.0 update 162)
JAWT version: 0x10004, CA_LAYER: false, isLayeredSurface false, bounds [ 0 / 0 1357 x 749 ], insets [ l 0, r 0 - t 0, b 0 - 0x0], pixelScale 1.0x1.0, shallUseOffscreenLayer false, isOffscreenLayerSurface false, attachedSurfaceLayer 0x0, windowHandle 0x8e00097, surfaceHandle 0x8e00097, bounds [ 0 / 0 1357 x 749 ], insets [ l 0, r 0 - t 0, b 0 - 0x0], window [0/0 1357x749], pixels[scale 1.0, 1.0 -> 1357x749], visible true, lockedExt false,
config AWTGraphicsConfiguration[AWTGraphicsScreen[AWTGraphicsDevice[type .awt, connection :0.0, unitID 0, awtDevice X11GraphicsDevice[screen=0], handle 0x0], idx 0],
chosen GLCaps[glx vid 0xc3, fbc 0x14a: rgba 8/8/8/8, opaque, accum-rgba 16/16/16/16, dp/st/ms 24/0/0, dbl, mono , hw, GLProfile[GL4bc/GL4bc.hw], on-scr[.]],
requested GLCaps[rgba 5/5/5/1, opaque, accum-rgba 0/0/0/0, dp/st/ms 16/0/0, dbl, mono , hw, GLProfile[GL4bc/GL4bc.hw], on-scr[.]],
X11GraphicsConfig[dev=X11GraphicsDevice[screen=0],vis=0xc3],
encapsulated X11GLXGraphicsConfiguration[X11GraphicsScreen[X11GraphicsDevice[type .x11, connection :0, unitID 0, handle 0x7fac3c202840, owner true, JAWTToolkitLock[obj 0x11617424, isOwner true, <791dbc57, 206cc8a5>[count 1, qsz 0, owner <J3D-Renderer-1>]]], idx 0], visualID 0xc3, fbConfigID 0x14a,
requested GLCaps[rgba 5/5/5/1, opaque, accum-rgba 0/0/0/0, dp/st/ms 16/0/0, dbl, mono , hw, GLProfile[GL4bc/GL4bc.hw], on-scr[.]],
chosen GLCaps[glx vid 0xc3, fbc 0x14a: rgba 8/8/8/8, opaque, accum-rgba 16/16/16/16, dp/st/ms 24/0/0, dbl, mono , hw, GLProfile[GL4bc/GL4bc.hw], on-scr[.]]]],
awtComponent com.eteks.sweethome3d.j3d.Component3DManager$ObservedCanvas3D[canvas2,0,0,1357x749],
surfaceLock <62f1c783, 7c895cd2>[count 1, qsz 0, owner <J3D-Renderer-1>]]]
at jogamp.opengl.x11.glx.X11GLXContext.createImpl(X11GLXContext.java:393)
at jogamp.opengl.GLContextImpl.makeCurrentWithinLock(GLContextImpl.java:765)
at jogamp.opengl.GLContextImpl.makeCurrent(GLContextImpl.java:648)
at jogamp.opengl.GLContextImpl.makeCurrent(GLContextImpl.java:586)
at javax.media.j3d.JoglPipeline.createNewContext(JoglPipeline.java:6411)
at javax.media.j3d.Canvas3D.createNewContext(Canvas3D.java:4602)
at javax.media.j3d.Canvas3D.createNewContext(Canvas3D.java:2376)
at javax.media.j3d.Renderer.doWork(Renderer.java:881)
at javax.media.j3d.J3dThread.run(J3dThread.java:271)
Error in Java 3D : 3 Renderer: Error creating Canvas3D graphics contextX11Util.Display: Shutdown (JVM shutdown: true, open (no close attempt): 2/2, reusable (open, marked uncloseable): 0, pending (open in creation order): 2)
X11Util: Open X11 Display Connections: 2
X11Util: Open[0]: NamedX11Display[:0, 0x7fac3c004a10, refCount 1, unCloseable false]
X11Util: Open[1]: NamedX11Display[:0, 0x7fac3c202840, refCount 1, unCloseable false]


Strangely, when running with iGPU Intel UHD 620, it's running nice.

Using SweetHome3D-Java3D-1_5_2 helps with nvidia

Need more infos?
[Aug 25, 2018 7:18:25 PM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Posts: 14   Pages: 2   [ Previous Page | 1 2 ]
[ Jump to Last Post ]
Show Printable Version of Thread  Post new Thread

    Get Sweet Home 3D at SourceForge.net. Fast, secure and Free Open Source software downloads
   
© Copyright 2006-2018 eTeks - All rights reserved