Features

Download

Online

Gallery

Blog

  Index  | Recent Threads  | List Attachments  | Help  | Search
 Welcome Guest  |  Register  |  Login
Login Name  Password
 

Sweet Home 3D Forum



No member browsing this thread
Thread Status: Active
Total posts in this thread: 37
Posts: 37   Pages: 4   [ 1 2 3 4 | Next Page ]
[ Jump to Last Post ]
Post new Thread
Author
Previous Thread This topic has been viewed 63435 times and has 36 replies Next Thread
Puybaret
Expert
Member's Avatar

France
Joined: Nov 7, 2005
Post Count: 5841
Status: Offline
Reply to this Post  Reply with Quote 
smile Sweet Home 3D 2.4

The first Beta of Sweet Home 3D 2.4 is available as a Java Web Start application.
At this time, its main new feature is the support for DAE/Collada file format: this means you have now access to Google 3D Warehouse and its huge library of 3D models!
For example, the following image contains only furniture and characters imported from Google 3D Warehouse:



This Beta version fixes also a few other things, among which:
- objets exported at OBJ format then reimported in Sweet Home 3D have now the same look (see this thread),
- the support for transparent textures was added,
- the bug that prevented overlapping floors to be correctly displayed is fixed.

Expect more features in the next Beta updates. biggrin


Developer comment: Sweet Home 3D 2.4 was released on 05/25/2010.
----------------------------------------
Emmanuel Puybaret, Sweet Home 3D developer
----------------------------------------
[Edit 1 times, last edit by Puybaret at May 25, 2010 10:29:22 PM]
[May 18, 2010 10:50:17 PM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest    http://www.eteks.com [Link] Report threatening or abusive post: please login first  Go to top 
db4tech
Advanced Member



UK
Joined: May 3, 2010
Post Count: 223
Status: Offline
Reply to this Post  Reply with Quote 
Re: Sweet Home 3D 2.4

Wow thanks! smile

One question is this a small bug or should it now be showing a full description path for the virtual vistor?



Also and this is something really small, the program icon is corrupt on Windows 7. It is fine with version 2.3.
Here is a 200% enlargement to help show the problem (the blue background was from my current desktop background and is not part of the icon)



db4tech
[May 18, 2010 11:44:07 PM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
hansmex
Advanced Member
Member's Avatar

Netherlands
Joined: Sep 26, 2009
Post Count: 3065
Status: Online
Reply to this Post  Reply with Quote 
Re: Sweet Home 3D 2.4

Emmanuel:

Both are the same on Ubuntu 10.04.

Hans
[May 19, 2010 5:40:33 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Puybaret
Expert
Member's Avatar

France
Joined: Nov 7, 2005
Post Count: 5841
Status: Offline
Reply to this Post  Reply with Quote 
Re: Sweet Home 3D 2.4

One question is this a small bug or should it now be showing a full description path for the virtual vistor?
It's a bug and I fixed it.
I noticed also that transparent textures don't work at this time at highest rendering quality level. I'll have to check if SunFlow can support that.

By the way, the DirectX version of Sweet Home 3D 2.4 Beta is also available.

Also and this is something really small, the program icon is corrupt on Windows 7. It is fine with version 2.3.
Thank you for mentioning it.
If you run Sweet Home 3D 2.3 from its installer version, I guess this is a bug in Java Web Start.
----------------------------------------
Emmanuel Puybaret, Sweet Home 3D developer
[May 19, 2010 7:27:18 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest    http://www.eteks.com [Link] Report threatening or abusive post: please login first  Go to top 
db4tech
Advanced Member



UK
Joined: May 3, 2010
Post Count: 223
Status: Offline
Reply to this Post  Reply with Quote 
Re: Sweet Home 3D 2.4

Thank you for the fixes.

I'm not a programmer but was the virtual visitor long description showing because a semicolon had been missed, separating the code description from the code?

One thing that may put people off testing the new version, this warning always shows (unless the 'Always trust...' box is ticked) with both the web start version and the DirectX version on Windows 7.


What are yours and others thoughts on moving a couple of things?
The Preferences from the File menu to the Edit menu. (Since changing preferences is editing something, plus most other programs have preferences found on the edit menu. Will help new users if preferences are where they are used to finding it, regular users will soon adapt to the change)

Also

Moving the Export to OBJ format... from the 3D view menu to the File menu since clicking on Export to OBJ format... always saves the full model and not just what is visible in the 3D view.

I was going to make these suggestions with version 2.3 but then thought you were busy with other things, so now is the perfect time when coding a new version.

db4tech

Edit: To fix a couple of typos.
----------------------------------------
[Edit 1 times, last edit by db4tech at May 19, 2010 1:27:25 PM]
[May 19, 2010 1:22:07 PM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
db4tech
Advanced Member



UK
Joined: May 3, 2010
Post Count: 223
Status: Offline
Reply to this Post  Reply with Quote 
Re: Sweet Home 3D 2.4

Also while you are coding your new version. Do you know about the growing Furniture catalog view: bug, causing all other windows to shrink? it happens with both versions 2.3 and 2.4, seems to happens for both Category folder and Searchable list options.

It only seems to happen when in full screen mode (maybe it's because I'm using a wide-screen display?)

If it's helpful I have made a tiny low resolution 18 seconds video to let you see what happens to the display each time a file is saved then opened again.

Sorry about giving you more work while you are busy working on advanced Uber shaders biggrin (just kidding!)

db4tech
----------------------------------------
Attachment Growing windows bug video.wmv (177523 bytes) (Download count: 385)

[May 19, 2010 11:32:40 PM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
hansmex
Advanced Member
Member's Avatar

Netherlands
Joined: Sep 26, 2009
Post Count: 3065
Status: Online
Reply to this Post  Reply with Quote 
Re: Sweet Home 3D 2.4

Gentlemen:

I cannot reproduce this bug on my PC (Ubuntu 10.04, screen 1680x1050, SH3D v2.4b2) or on my laptop (Windows Vista, screen ?, SH3D v2.3)

Hans
[May 20, 2010 7:40:33 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Puybaret
Expert
Member's Avatar

France
Joined: Nov 7, 2005
Post Count: 5841
Status: Offline
Reply to this Post  Reply with Quote 
Re: Sweet Home 3D 2.4

was the virtual visitor long description showing because a semicolon had been missed, separating the code description from the code?
It's just a misplaced end of line delimiter in the resource file that gives the menu names displayed in English.

One thing that may put people off testing the new version, this warning always shows (unless the 'Always trust...' box is ticked) with both the web start version and the DirectX version on Windows 7.
This security dialog is displayed for any Java Web Start version of Sweet Home 3D and for the online version too.
In a way, it's not normal that the installer versions under Windows and Linux don't display such a dialog, because the user should always be warned about the risks of launching a program able to write on the disk, run DLLs...
The only improvement I can do in this dialog is about the "cannot be verified" text: if I buy a Java Code Signing Certificate, it will say "has been verified", but this certificate costs at least 200 $/year! Not sure it's worth it for a free program... sad

What are yours and others thoughts on moving a couple of things?
The Preferences from the File menu to the Edit menu. (Since changing preferences is editing something, plus most other programs have preferences found on the edit menu. Will help new users if preferences are where they are used to finding it, regular users will soon adapt to the change)
My stupid answer would be "use Mac OS X"! wink
Under Mac OS X, they solved this problem by proposing the Preferences item in the application menu displayed for each program. Here's the French application menu for Sweet Home 3D:



On other systems, I miserably didn't see any common rule; Preferences are sometimes in a Tool menu, sometimes in the File menu, sometimes in the Edit menu or elsewhere, and often it's named Options and not Preferences!
So sorry I won't move it.

Moving the Export to OBJ format... from the 3D view menu to the File menu since clicking on Export to OBJ format... always saves the full model and not just what is visible in the 3D view.
This remark is applicable to the Export to SVG format... menu item too, and any Export to ... format that will appear in the future. sad
Even if these menu items handle files, I chose to put these items in the Plan and 3D view menus to suggest to beginners what kind of information would be exported.

Do you know about the growing Furniture catalog view: bug, causing all other windows to shrink?
I'm not aware of this problem.
Do you mean that the Furniture catalog view grows without doing anything like in the video??? When does it stop growing?
----------------------------------------
Emmanuel Puybaret, Sweet Home 3D developer
[May 20, 2010 9:07:58 AM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest    http://www.eteks.com [Link] Report threatening or abusive post: please login first  Go to top 
db4tech
Advanced Member



UK
Joined: May 3, 2010
Post Count: 223
Status: Offline
Reply to this Post  Reply with Quote 
Re: Sweet Home 3D 2.4

Hi Emmanuel and Hans,

Each frame (or window position change) in the video shows what happens when a Sweet Home file is saved, the Sweet Home program is closed, next the file is opened again, file is saved (without making a changes) close the program, open the file and save the file again and so on.

Each frame of the video shows one screen capture when the Sweet Home file is opened.

Under normal use the windows only change (jump) once and I drag them back to the original positions before doing any work on the Sweet Home building before saving.

The video was created to see just how far the windows would keep moving if the user didn't keep dragging them back.

Hope this makes sense.

Emmanuel, to answer your question, the end of the video shows the maximum distance the windows seem to travel.

To help isolate what might be causing this (in case it was a hardware driver problem or operating system issue) I have just tested it for you using XP Pro under visualization (completely different OS and drivers for virtual hardware) and also a slightly older version of java and it does exactly the same thing, in windowed mode everything stays the same but once the program is full screen the widows change/jump positions (only) once, as soon as a file is opened.

I'm using a 16x9 aspect ratio display if it's helpful.

PS: I don't think I will be buying a Mac just so the preferences show in a different place. wink

db4tech
[May 20, 2010 3:27:18 PM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
db4tech
Advanced Member



UK
Joined: May 3, 2010
Post Count: 223
Status: Offline
Reply to this Post  Reply with Quote 
Re: Sweet Home 3D 2.4

Moving the Export to OBJ format... from the 3D view menu to the File menu since clicking on Export to OBJ format... always saves the full model and not just what is visible in the 3D view.
This remark is applicable to the Export to SVG format... menu item too, and any Export to ... format that will appear in the future. sad
Even if these menu items handle files, I chose to put these items in the Plan and 3D view menus to suggest to beginners what kind of information would be exported.


Ah but Export to SVG format... makes sense under the Plan menu option as it is just the plan view that is converted to SVG.

The Export to OBJ format... differs as the whole model (not just what is visible in the 3D view is converted to an obj file) since it is located under the 3D view menu I thought new users might think only what they see in the 3D view is converted to an obj.

db4tech
[May 20, 2010 3:38:32 PM] Show Printable Version of Post    View Member Profile    Send Private Message    Hidden to Guest [Link] Report threatening or abusive post: please login first  Go to top 
Posts: 37   Pages: 4   [ 1 2 3 4 | Next Page ]
[ Jump to Last Post ]
Show Printable Version of Thread  Post new Thread

    Get Sweet Home 3D at SourceForge.net. Fast, secure and Free Open Source software downloads
   
© Copyright 2006-2017 eTeks - All rights reserved